1. Shadowblockz now supports 1.7 and 1.8 clients.
    1.7.10 is recommended.
    There are currently no 1.8 features implemented. We are waiting on a 1.8 Bukkit build

Vote

Vote on the following links for rewards on each server!
At the start of each month, the top 4 voters and a
random voter from the previous month will be given rewards.

___________________________________________________________________________________________________

 

 

 

  

 

 

___________________________________________________________________________________________________

 

 

TOP VOTERS

Share This Page